Issues

ZF-10291: PHP Fatal error: Class 'Zend_Uri_Http' not found

Description

I use Gdata standalone version 1.10.7 and i get this on i try to use the youtube demo. Class 'Zend_Uri_Http' not found in /hsphere/local/home/user/domain.net/Zend/Gdata/App.php on line 643.

I don't understand why. I checked installationchecker.php and it doesn't give me any error.

Another thing is that on localhost the demo works fine(xampp).

the php version installed is 5.2.6

this is the array returned by the function get_loaded_extensions()

Array ( [0] => libxml [1] => xsl [2] => xmlwriter [3] => dom [4] => xmlreader [5] => xml [6] => tokenizer [7] => session [8] => pcre [9] => SimpleXML [10] => sockets [11] => SPL [12] => standard [13] => Reflection [14] => posix [15] => mime_magic [16] => mhash [17] => mcrypt [18] => mbstring [19] => json [20] => hash [21] => gettext [22] => gd [23] => ftp [24] => filter [25] => dba [26] => date [27] => ctype [28] => bz2 [29] => zlib [30] => openssl [31] => apache2handler [32] => bcmath [33] => calendar [34] => curl [35] => dbase [36] => exif [37] => fileinfo [38] => gmp [39] => iconv [40] => imap [41] => ldap [42] => mysql [43] => mysqli [44] => odbc [45] => PDO [46] => pdo_mysql [47] => pdo_pgsql [48] => pdo_sqlite [49] => pgsql [50] => pspell [51] => soap [52] => SQLite [53] => ionCube Loader [54] => Zend Optimizer )

Comments

Please provide some code with which this issue can be reproduced.

is operations.php from gdate demo: YouTubeVideoApp. i didn't do any changes to it. operations.php and "Zend" folder are in the same directory

require_once 'Zend/Loader.php'; Zend_Loader::loadClass('Zend_Gdata_YouTube'); Zend_Loader::loadClass('Zend_Gdata_AuthSub'); Zend_Loader::loadClass('Zend_Gdata_App_Exception');

/* * The main controller logic. * * POST used for all authenticated requests * otherwise use GET for retrieve and supplementary values */ session_start(); setLogging('on'); generateUrlInformation();

Fixed with r22972.