Issues

ZF-10830: Make testsuite compatible with PHPUnit 3.5.5

Description

The testsuite for ZF isn't compatible with PHPUnit 3.5.5 Since we're still using PHPUnit 3.4 for our QA processes, we need to retain 3.4 compatability.

Comments

Fixed in svn r23508

fix in r23508 had 2 issues:

TestHelper.php raised a PHP warning in PHPunit 3.4, and there was a call to PHP_CodeCoverage_Filter in tests/Zend/Config/Writer/AllTests.php

These problems are now also fixed in svn r23509

Applied on Extras library with r23645