ZF-11999: Zend Form translate Element twice

Description

Hi,

I am having one issue, zend form is translating the element labels twice.

So I am getting notices but the content was already translated.

Notice: Untranslated message within 'pt': Usuário in C:\xampp\ZendFramework-1.11.11\library\Zend\Translate\Adapter.php on line 837 Call Stack

Time Memory Function Location

1 0.0013 342672 {main}( ) ..\index.php:0 2 0.6097 8966664 Zend_Application->run( ) ..\index.php:30 3 0.6097 8966664 Zend_Application_Bootstrap_Bootstrap->run( ) ..\Application.php:366 4 0.6098 8966720 Zend_Controller_Front->dispatch( ) ..\Bootstrap.php:97 5 0.7911 10669224 Zend_Controller_Dispatcher_Standard->dispatch( ) ..\Front.php:954 6 0.8168 10969520 Zend_Controller_Action->dispatch( ) ..\Standard.php:295 7 0.8678 12524096 Zend_Controller_Action_HelperBroker->notifyPostDispatch( ) ..\Action.php:527 8 0.8679 12524856 Zend_Controller_Action_Helper_ViewRenderer->postDispatch( ) ..\HelperBroker.php:277 9 0.8680 12524856 Zend_Controller_Action_Helper_ViewRenderer->render( ) ..\ViewRenderer.php:960 10 0.8699 12525048 Zend_Controller_Action_Helper_ViewRenderer->renderScript( ) ..\ViewRenderer.php:921 11 0.8731 12525048 Zend_View_Abstract->render( ) ..\ViewRenderer.php:900 12 0.8760 12566256 Zend_View->_run( ) ..\Abstract.php:888 13 0.8773 12629360 include( 'C:\htdocs\locatephone\LocatePhoneWeb\application\modules\default\views\scripts\index\index.phtml' ) ..\View.php:108 14 0.8833 12629912 Zend_Form->__toString( ) ..\Form.php:41 15 0.8833 12629912 Zend_Form->render( ) ..\Form.php:2920 16 0.8980 12808896 Zend_Form_Decorator_FormElements->render( ) ..\Form.php:2904 17 0.8989 12809680 Zend_Form_Element->render( ) ..\FormElements.php:111 18 0.9276 13112600 Zend_Form_Decorator_Label->render( ) ..\Element.php:2043 19 0.9277 13112600 Zend_Form_Decorator_Label->getLabel( ) ..\Label.php:339 20 0.9278 13112656 Zend_Translate_Adapter->translate( ) ..\Label.php:304 21 0.9283 13112736 Zend_Translate_Adapter->_log( ) ..\Adapter.php:784 22 0.9283 13112896 trigger_error ( ) ..\Adapter.php:837

Comments

This issue duplicates ZF-8694.