ZF-12055: Gdata only download is packaged incorrectly

Description

The gdata download includes Loader.php but not Loaders/AutoLoader.php this means that it breaks when using the loader.

I've tested using this code: <?php error_reporting(E_ALL); set_include_path(get_include_path() . ':' . realpath(dirname(FILE)) . '/ZendGdata-1.11.11/library/'); require_once(realpath(dirname(FILE)) . '/ZendGdata-1.11.11/library/Zend/Loader.php'); Zend_Loader::registerAutoload();

I get this output: Notice: Zend_Loader::Zend_Loader::registerAutoload is deprecated as of 1.8.0 and will be removed with 2.0.0; use Zend_Loader_Autoloader instead in /home/dean/public_html/yt/ZendGdata-1.11.11/library/Zend/Loader.php on line 266 Warning: require_once(Zend/Loader/Autoloader.php): failed to open stream: No such file or directory in /home/dean/public_html/yt/ZendGdata-1.11.11/library/Zend/Loader.php on line 267 Fatal error: require_once(): Failed opening required 'Zend/Loader/Autoloader.php' (include_path='.:/usr/share/php:/usr/share/pear:/home/dean/public_html/yt/ZendGdata-1.11.11/library/') in /home/dean/public_html/yt/ZendGdata-1.11.11/library/Zend/Loader.php on line 267

Comments

No comments to display