Issues

ZF-12442: libxml_disable_entity_loader() call in ZF 1.12

Description

Hi, I have updated from ZF 1.11 to ZF 1.12 and found that I can`t use my SOAP calls. In Zend/Soap/Server.php on line 732 is method libxml_disable_entity_loader() called, but this method is available from PHP >= 5.2.11. I am running on

PHP 5.2.0-8+etch16 (cli)

and actually can not update until some issues are fixed or reimplemented. In install requirements instructions for ZF 1.12 you write that you need minimum PHP 5.2.4 or later (http://framework.zend.com/manual/1.12/…) so that is also my fault we run on 5.2.0 but this method libxml_disable_entity_loader() is only available from PHP 5.2.11. (http://php.net/manual/en/…) So do you think about providing some patch for this (that would be just awesome) or will you update the requirements install instructions for ZF 1.12 for this issue and change the minimal version from 5.2.4 as you write to 5.2.11?


Zend recommends the most current release of PHP for critical security and performance enhancements, and currently supports PHP 5.2.11 or later.

Thank you very much for your time&effort!

Comments

As this is the result of a security fix, we have updated the minimum version of PHp for ZF 1.12 to be 5.2.11

Hi, thank you for new info. In ZF v. 1.12. documentation is still written PHP 5.2.4 Thanks for your time.

Hi,

Where are you looking? The change so far has been made in the source code.

Hi, here, to reference manual http://framework.zend.com/manual/1.12/… Karel

Okay. That should automatically change when we release 1.12.1.