ZF-2529: Make Zend_Db_Statement_Mysqli incorporate with PHP 5.3 and mysqlnd

Description

mysqli_stmt_bind_param() expects bind parameters to be references, not values. The following patch ensures that references are given.

Comments

Updated the patch. The type definition should not be a reference.

Please categorize/fix as needed.

Hi,

Any news about this patch ? I have to apply it to every release I get from ZF Website. It is a fix to a major bug I think.

Reassigning to Ralph to bring closure to this issue.

I applied the 1/31/08 patch against Zend Framework 1.8.1 and still get this issue with PHP 5.3 RC built on 5/21/09. Any news on this bug?

strange thing, i've applied this path and everything work well. perhaps you've either missed something or applied a path incorrectly. besides, this path would make sense after php 5.3 is released and it should be rearranged to gain back and forth compatibility

This patch still need to be applied on ZF 1.8.1 when used with PHP 5.3RC2.

Reapplied the patch and it worked this time, so I must have done something wrong the first time.

Any ideas when this will make it into trunk or is it just planned to be among the updates for Zend Framework to work with 5.3?

I invented the same bicycle today when my site stopped working after upgrading to PHP 5.3.0 (released yesterday). I think it's time to fix the trunk already.

Ill run the tests one more time and close, this was fixed in 1.9.0 release though.

-ralph