ZF-2803: PHP 5.3 compatibility for Zend_Cache_Backend_File

Description

Zend_Cache_Backend_File checks for runtime magic quotes. The following patch a) checks whether the function is available (as the functions are removed in PHP 6) and b) suppresses the E_DEPRECATED warning.

Comments

fixed in SVN trunk (thanks)

Sorry, but your fix is incomplete. PHP 5.3 introduces E_DEPRECATED. E_DEPRECATED is part of E_STRICT and when set/get_magic_quotes() is called, a deprecation warning is thrown. This means, you have to disable errors with @ in addition to checking whether the function is available as like I did it in my original patch.

(again) many thanks

This issue should have been fixed for the 1.5 release.

Yes, error suppression is very nice in a production environment, but my development environment does not suppress errors/notices and this problem still persists.

Please fix this, it should not use a deprecated function.

Thank you for your work!