ZF-4501: Unable to query database.

Description

I am receiving the following error when I attempt to instantiate an extended Zend_Db_Table_Abstract object.

I am able to use the native db2_connect() methods to connect to the database and perform queries.

Fatal error: Uncaught exception 'Zend_Db_Statement_Db2_Exception' with message 'COLUMNS in SYSCAT type *FILE not found. SQLCODE=-204' in /usr/local/Zend/ZendFramework/library/Zend/Db/Statement/Db2.php:69 Stack trace: #0 /usr/local/Zend/ZendFramework/library/Zend/Db/Statement.php(109): Zend_Db_Statement_Db2->_prepare('SELECT DISTINCT...') #1 /usr/local/Zend/ZendFramework/library/Zendc/Db/Adapter/Db2.php(215): Zend_Db_Statement->__construct(Object(ZendC_Db_Adapter_Db2), 'SELECT DISTINCT...') #2 /usr/local/Zend/ZendFramework/library/Zend/Db/Adapter/Abstract.php(429): ZendC_Db_Adapter_Db2->prepare('SELECT DISTINCT...') #3 /usr/local/Zend/ZendFramework/library/Zendc/Db/Adapter/Db2.php(430): Zend_Db_Adapter_Abstract->query('SELECT DISTINCT...') #4 /usr/local/Zend/ZendFramework/library/Zend/Db/Table/Abstract.php(604): ZendC_Db_Adapter_Db2->describeTable('ADDRESSTYPE', NULL) #5 /usr/local/Zend/ZendFramework/library/Zend/Db/Table/Abstract.php(533): Zend_Db_Table_Abstract->_setupMetadata() #6 /usr/local/Zend/ZendFramework/library/Z in /usr/local/Zend/ZendFramework/library/Zend/Db/Statement/Db2.php on line 69

Comments

http://publib.boulder.ibm.com/infocenter/db2luw/… maybe telling what version of DB2 you are running would be usefull

Is this still an issue? Reporter, have you tried resolving this on the mailing list?

I had circumvented this issue by using the "temporary" Db2 adapter (located in Zendc/Db/Adapter). Yesterday I upgraded our framework to version 1.7.1 and I am getting this error again.

My ini file looks like this:
db.adapter = Db2 db.params.username = MY_USER db.params.password = ************* db.params.schema = MY_SCHEMA db.params.dbname = MY_DB

The bootstrap creates the adapter this way: $config = new Zend_Config_Ini('../application/default/configs/wtu.ini', 'development'); $db = Zend_Db::factory($config->db); Zend_Db_Table::setDefaultAdapter($db);

My system info is as follows: Zend Core Version 2.6.0 PHP Version 5.2.6 Zend Engine Version 2.2.0 Server API apache2handler PHP Configuration File /usr/local/Zend/core/etc/php.ini Server Name 127.0.0.1 Server Software Apache/2.2.6 (Unix) Zend Core/2.6.0 PHP/5.2.6 OS Version OS400 LAB 4 5 0010000907DD Server Port 8000

Hey Simon,

Can you try this code from standard library trunk: http://framework.zend.com/code/changelog/…

Specifically the DB2 adapter in there.

is this still an issue? have you had a chance to try the adapter in 1.7.2?

please reopen if this is still an issue