ZF-4851: Problem with getFileInfo() in Zend_File_Transfer_Adapter_Abstract


I'm use… revision:12282

This code is Error.

$form->addElement('file', 'logo', array(
                    'required' => true,
                    'validators' => array(
                              array('Count', true, 2),
                              array('Size', true, "100KB"),
                              array('Extension', true, 'jpg'),
                    'multiFile' => 1,

Render page. Error occured....

Error is [ Warning: "logo" not found by file transfer adapter in... ].

Why error occured?

So i edited Zend/File/Transfer/Adapter/Abstract.php :: getFileInfo()

public function getFileInfo($file = null) { return $this->_getFiles($file); }

↓ It changed.

public function getFileInfo($file = null) { return $this->_getFiles($file, false, true); }

The error did not happen.

please fix this problem.


There was an error in multifile which has been solved one or two days after the release has been fixed.

It is solved in 1.7.

Changing issues in preparation for the 1.7.0 release.