ZF-5054: Update requirements appendix of manual

Description

The requirements appendix needs to be updated to show: * Now requiring PHP >= 5.2.4 * Now requiring PHPUnit >= 3.3.0

Comments

Updated in r12887.