Issues

ZF-6172: Validate .com domaine with Zend_Feed

Description

Hello,

When i open a new feed with this code: $canal = new Zend_Feed_Atom(my_url_dot_com);

I got these errors:

line: 62 inet_pton() : Unrecognized address www.XXX.com Zend/Validate/Ip.php

line: 165 fopen(Zend/Validate/Hostname/Com.php) : failed to open stream: No such file or directory Zend/Loader.php

Comments

Support for COM IDNs has been added 2 weeks ago within trunk. Before that COM was only recognised if it contained no IDN characters.

Hi,

It seems to not be fully fixed into 1.8.0.

I still get this error: line: 62 inet_pton() : Unrecognized address www.XXX.com Zend/Validate/Ip.php

But this one is fixed: line: 165 fopen(Zend/Validate/Hostname/Com.php) : failed to open stream: No such file or directory Zend/Loader.php

Check your installation. The file mentioned by fopen can be found within the release 1.8.

Maybe you have mixed old and new installations ?

Yes, fopen is fixed, i'm ok with that. But not the warning with inet_pton(). I reported 2 errors, but only 1 was fixed.

With ZF 1.7.7, i get 2 errors: line: 62 inet_pton() : Unrecognized address www.XXX.com Zend/Validate/Ip.php

line: 165 fopen(Zend/Validate/Hostname/Com.php) : failed to open stream: No such file or directory Zend/Loader.php

With ZF 1.8.0, i get 1 error: line: 62 inet_pton() : Unrecognized address www.XXX.com Zend/Validate/Ip.php

Regards,

I'm sorry but you filled a issue for 3 components. This is always a bad idea and problematic.

The COM issue is part of Zend_Validate_Hostname and is fixed. There were other related issues.

I am not able to reproduce the inet_pton issue because there is a error-supression activated. It was not at 1.7... so why are you getting an error when there is no error thrown ? There are also no other issues related to such a problem.

Are you using a own error handler which returns supressed errors ?

The Zend_Feed issue is another thing... not sure why you can not open a feed for a com domain. When the Ip validator is cleared I will reopen this issue and unassign it as I am not Zend_Feed's developer.