ZF-6243: Failed require for Zend/Search/Lucene/TermStreamsPriorityQueue.php

Description

In r14744 a require() was added to line 70 of the Zend/Search/Lucene.php file:

69 + /** Zend_Search_Lucene_TermStreamsPriorityQueue */ 70 + require_once 'Zend/Search/Lucene/TermStreamsPriorityQueue.php';

But this file does not exist in the repository.

This results in the following error:

Warning: require_once(Zend/Search/Lucene/TermStreamsPriorityQueue.php) [function.require-once]: failed to open stream: No such file or directory in /home/david/public_html/qubit/plugins/sfLucenePlugin/lib/vendor/Zend/Search/Lucene.php on line 70

Fatal error: require_once() [function.require]: Failed opening required 'Zend/Search/Lucene/TermStreamsPriorityQueue.php' (include_path='/home/david/public_html/qubit:/home/david/public_html/qubit/lib/vendor/symfony/lib/plugins/sfPropelPlugin/lib/vendor/propel-generator/classes:/home/david/public_html/qubit/plugins/sfLucenePlugin/lib/vendor:/home/david/public_html/qubit/lib/vendor/symfony/lib:/home/david/public_html/qubit/lib/vendor/symfony/lib/plugins/sfPropelPlugin/lib/vendor:/home/david/public_html/qubit/lib/vendor/symfony/lib/plugins/sfPropelPlugin/lib/task:/home/david/public_html/qubit/plugins/sfLucenePlugin/lib/vendor:.:/usr/share/php:/usr/share/pear') in /home/david/public_html/qubit/plugins/sfLucenePlugin/lib/vendor/Zend/Search/Lucene.php on line 70

Comments

fixed with r14773

That's great, thank Alexander! :-) I tested locally and it's all working fine now.

Cheers, David