Issues

ZF-6460: Stripping all require_once calls makes Zend_Loader_Autoloader unable to work

Description

h4. What?

if you follow this step of the documentation: Classloading performance. Zend_Loader_Autoloader does not longer work!

h4. Why? Because Zend_Loader_Autoloader requires Zend_Loader - but we strip out the required "require 'Zend/Loader.php';".

h4. Solution? Change the documentation to something like this:

 
% cd path/to/ZendFramework/library
% find . -name '*.php' -not -wholename '*/Loader/Autoloader.php' -print0 | xargs -0 \
  sed --regexp-extended --in-place 's/(require_once)/\/\/ \1/g'

Comments

Fixed in trunk and 1.8 release branch; will update on site with 1.8 release.