Issues

ZF-6605: Zend_Loader::registerAutoload() should proxy to Zend_Loader_Autoloader

Description

While Zend_Loader::registerAutoload() is deprecated, it should proxy to Zend_Loader_Autoloader, setting it as a fallback autoloader and otherwise maintaining the same behavior.

Comments

Stupid question, but: why?

Please see these two emails from fw-general for more information: * http://nabble.com/Re%3A-Replacing-Zend_Loader-by-Z… * http://nabble.com/Re%3A-Replacing-Zend_Loader-by-Z…

Basically, proxying to Zend_Loader_Autoloader eliminates the duplicate deprecation notices, and also provides a direct migration path for developers.

Resolved in trunk and 1.8 release branch.