Issues

ZF-7521: The Zend Tool zf.php script uses $_ENV instead of getenv(), in recent releases of php, the $_ENV superglobal is not populated in the recommended php.ini file

Description

Recent versions of the distributed/recommended php.ini file state that the superglobal variable order should be "GPCS" (i.e. variables_order = "GPCS"). Since E is omitted, the $_ENV superglobal is never populated and the ini file recommends always using getwnv() in preference to $_ENV.

The Zend Tool zf.php file uses $_ENV and getenv() erratically, sometimes checking for the existence of an environment var with getenv() and then assuming it's existence by referencing the $_ENV array. All references in this file should use getenv().

Comments

I have attached the file with $_ENV factored out in favor of getenv()

Fixed in trunk in r17522 and 1.9 release branch in r17524

Updating fix information