ZF-9797: Zend_Markup_Parser_Textile is unusable

Description

Zend_Markup_Parser_Textile is in an unusable state I'm afraid. Using it in a production environment with real users writing real comments/articles wreaks havoc :(

Sample text; "Hi!"

Expected output: "

Hi!

"

Resulting output: "

Hi

"

The exclamation mark is stripped. This problem gets worse if you have something like this.

Sample text: "Hi! Check out "this link":http://google.com. Yay!"

Expected output: "Hi! Checkout this link. Yay!"

Resulting output: "

HiCheck out &quot;this link&quot;:<a rel=http://google.com. Yay" alt="google" />

"

  • -

Also, Zend_Markup_Renderer_RendererAbstract has a call to $this->removeDefaultTags(); in the constructor. No such method is defined in Zend_Markup_Renderer_RendererAbstract or in Zend_Markup_Renderer_Html.

  • -

Was Zend_Markup supposed to be production ready? If not, my apologies for misunderstanding the situation!

Comments

It looks like all the tags in the {{$_simpleTags}} property suffer from this.

The check for tags only searches for 1 occurence (not enclosed tags).


$textile = Zend_Markup::factory('Textile');

echo $textile->render('Hi!');
// 

Hi

echo $textile->render('!Hi'); //

echo $textile->render('Hi*'); //

Hi

echo $textile->render('*Hi'); //

Hi

echo $textile->render('Hi! Check out "this link":http://google.com. Yay!'); //

HiCheck out &quot;this link&quot;:<a rel=http://google.com. Yay" alt="google" />

Could I ask if there's a status update on this since May? I'd really like to use Textile in my app (preferably Markdown but I just need some sort of formatting).

If it helps here is a www.textism.com/tools/textile/?sample=2" rel="nofollow">great sample you can use for testing.

I am also interested in Textile. Now I am forced to use native implementation from http://textile.thresholdstate.com/.

Are there any plans on this issue?

27 oct the last update, changed from major to critical... if critical bugs take this long to fix, how long does it take to get major issues to be fixed?!

Please people, FIX THIS ASAP, this way the textile parser is realy not a viable option to use...

Besides the obvious bug this issue describes... there is more:

http://textile.thresholdstate.com/

This page allows you to see what is supposed to be possible using textile, but something basic as ==== and notextile. are unknown to the parser ...

This renders it just about unusable...

How is it possible that Zend_Markup_Parser_Textile, in this state, has made it to a stable ZF-release?

My recommendation is that unless someone steps up to fix this component for v1.12 it should be removed

On the grounds that no-one has volunteered to fix this. I have removed Zend_Markup_Parser_Textile from trunk (25156) and release-1.12 (25157).