compared with
Key
This line was removed.
This word was removed. This word was added.
This line was added.

Changes (2)

View Page History
{toggle-cloak:id=GenPHP4} *Does Zend Framework support PHP 4?*
{cloak:id=GenPHP4}
Zend Framework was built to use all of the advanced object oriented features of PHP 5. Since PHP 4 is not fully forwards compatible with PHP 5, the Zend Framework community was faced with the decision of committing to support PHP 4 or leveraging existing and future enhancements in PHP 5 from the outset. We felt the overall value proposition was tipped in favor of features, performance, and security enhancements in PHP 5. The PHP community officially discontinued support for PHP 4 as of 2008-01-01, and no critical security updates will be published for PHP 4 after 2008-08-08.
No. Zend Framework was built to use all of the sophisticated object oriented features of PHP 5 and take advantage of significant performance and security enhancements.

Another consideration was support of the platform ZF would be running on. The PHP community officially discontinued support for PHP 4 as of 2008-01-01, and no critical security updates will be published for PHP 4 after 2008-08-08.

These factors, among others, convinced us that PHP 5 was the best platform for Zend Framework and applications built on ZF.
{cloak}