ZF-10414: Incongruency between Zend_View docs and Advisory - Default encoding

Issue Type: Docs: Improvement Created: 2010-09-03T05:25:48.000+0000 Last Updated: 2010-09-06T21:56:42.000+0000 Status: Resolved Fix version(s): - 1.11.1 (30/Nov/10)

Reporter: jw (ronny stalker) Assignee: Matthew Weier O'Phinney (matthew) Tags: - Zend_View

Related issues: - ZF-9382



In the Zend_View Docs at (Version 1.10):…

it says: "encoding: indicate the character encoding to use with htmlentities(), htmlspecialchars(), and other operations. Defaults to ISO-8859-1 (latin1). May be set via setEncoding() or the encoding option to the constructor. "

In the advisory at:…

it says: "The afore-mentioned [Zend_View] classes have been reworked to use a default character encoding of UTF-8...a decision was made to default to UTF-8 for the internal encoding mechanisms used by Zend_View. "

These two documents seem to be conflicting.

Although, looking into my Zend_View object (version 1.9.8) it appears that it does default to UTF-8 - so the Documentation for Zend View is more likely to be the wrong one.

<pre class="highlight"> 
abstract class Zend_View_Abstract implements Zend_View_Interface

     * Encoding to use in escaping mechanisms; defaults to utf-8
     * @var string
    private $_encoding = 'UTF-8';



Posted by Matthew Weier O'Phinney (matthew) on 2010-09-03T06:23:01.000+0000

Thanks for the report -- the issue was indeed in the documentation, and I've updated it in trunk and the 1.10 release branch.

Have you found an issue?

See the Overview section for more details.


© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.