ZF-10805: method docblocks contain invalid @param syntax

Issue Type: Bug Created: 2010-12-10T00:06:49.000+0000 Last Updated: 2011-02-25T14:23:05.000+0000 Status: Resolved Fix version(s): - 1.11.3 (01/Feb/11)

Reporter: Marc Hodgins (mjh_ca) Assignee: Phoenix Zerin (todofixthis) Tags: Related issues: Attachments: -


According to phpDocumentor, the correct format of @param is:

<pre class="literal">
@param datatype $paramname description

There are some instances in the codebase where the datatype is omitted or the terms are out of order (i.e. @param $foo string)

For example, run this in the library dir:

<pre class="literal">
find . -name '*.php' -print0 | xargs -0 grep -P '@param[ ]+\$'

The main side effect is that IDEs are generally be unable to do correct code completion/hinting for these methods.


Posted by Phoenix Zerin (todofixthis) on 2010-12-25T06:17:03.000+0000

I'll start working on this. 76 files are affected as of r23578.

Posted by Phoenix Zerin (todofixthis) on 2010-12-25T07:37:52.000+0000

Patch for bin, demos, library and tests attached.

Posted by Thomas Weidner (thomas) on 2010-12-26T09:21:31.000+0000

Reopening issues Please don't resolve issues as fixed without doing a commit

Posted by Mickael Perraud (mikaelkael) on 2011-01-21T13:33:18.000+0000

Patch applied with r23650. Thanks.

Posted by Thomas Weidner (thomas) on 2011-02-25T14:23:05.000+0000

Fixed with GH-99 on ZF2

Have you found an issue?

See the Overview section for more details.


© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.