ZF-10830: Make testsuite compatible with PHPUnit 3.5.5

Issue Type: Improvement Created: 2010-12-15T10:06:07.000+0000 Last Updated: 2011-01-21T09:33:25.000+0000 Status: Closed Fix version(s): - 1.11.2 (30/Dec/10)

Reporter: Andries Seutens (andries) Assignee: Andries Seutens (andries) Tags: Related issues: - ZF-10849



The testsuite for ZF isn't compatible with PHPUnit 3.5.5 Since we're still using PHPUnit 3.4 for our QA processes, we need to retain 3.4 compatability.


Posted by Andries Seutens (andries) on 2010-12-15T10:18:29.000+0000

Fixed in svn r23508

Posted by Andries Seutens (andries) on 2010-12-15T10:31:54.000+0000

fix in r23508 had 2 issues:

TestHelper.php raised a PHP warning in PHPunit 3.4, and there was a call to PHP_CodeCoverage_Filter in tests/Zend/Config/Writer/AllTests.php

These problems are now also fixed in svn r23509

Posted by Mickael Perraud (mikaelkael) on 2011-01-21T09:33:22.000+0000

Applied on Extras library with r23645

Have you found an issue?

See the Overview section for more details.


© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.