Issues

ZF-11174: Google Base APIs being deprecated in favor of Google Content/Shopping APIs (effective June 1, 2011)

Issue Type: Bug Created: 2011-03-15T05:24:30.000+0000 Last Updated: 2012-05-04T23:29:48.000+0000 Status: Closed Fix version(s): Reporter: Seth Mead (smead2124) Assignee: Adam Lundrigan (adamlundrigan) Tags: - Zend_Gdata

Related issues: Attachments:

Description

Hello,

I wondered if Zend Framework was planning on supporting the new Google Shopping APIs?

Please see e-mail from Google:

Hello,

Thank you for participating in Google Shopping. According to our records, you're currently using the Google Base Data API to submit your product listings to Google Product Search. On December 17, 2010, we announced the retirement of the Google Base Data API and transition to the new Google Content API for Shopping (http://googlemerchantblog.blogspot.com/2010/12/…).

Starting from June 1st, 2011, it will no longer be possible to submit content using the Google Base Data API. In order for you items to continue appearing in Google Product Search results without interruption, we encourage you to start transitioning to the new Content API as soon as possible.

The following resources will guide you through the transition:

Content API documentation: http://code.google.com/apis/shopping/content/ Google Base Data API Deprecation FAQ: http://code.google.com/apis/base/faq_depr.html Migrating to the Content APIs for Shopping: https://code.google.com/apis/shopping/… Google Content API for Shopping developers forum: https://groups.google.com/group/…

Sincerely,

The Google Merchant Center Team

© 2011 Google Inc. 1600 Amphitheatre Parkway, Mountain View, CA 94043

You have received this mandatory email service announcement to update you about important changes to your Google Merchant Center product or account

Comments

Posted by Clare Coyne (claredhd) on 2011-04-10T20:52:14.000+0000

I rely on the Zend Gdata classes for my application. I would really appreciate if the GData library could be updated to work with the new Google Shopping API. Their date for ending the base API is looming!

Many Thanks Clare

Posted by Adam Lundrigan (adamlundrigan) on 2011-10-31T15:05:17.000+0000

Is there any plan to implement/fix this in ZFv1?

Posted by Adam Lundrigan (adamlundrigan) on 2012-05-04T23:29:48.000+0000

It is highly unlikely that Zend_Gdata will be supporting the replacement APIs for Zend_Gdata_Gbase, or any other non-GData-based Google APIs. Google's GData APIs are being phased out, and as such they are no longer officially maintaining this component (Zend_Gdata).

The best alternative is to use the PHP APIs provided by Google via their Google Developers web portal.

Have you found an issue?

See the Overview section for more details.

Copyright

© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.

Contacts