ZF-12307: Zend_Loader_StandardAutoloader incorect check for PHP version

Issue Type: Bug Created: 2012-06-26T16:57:01.000+0000 Last Updated: 2012-06-30T19:28:10.000+0000 Status: Resolved Fix version(s): Reporter: Martin Hujer (mhujer) Assignee: Matthew Weier O'Phinney (matthew) Tags: - Zend_Loader

  • FixForZF1.12

Related issues: Attachments: - ZF-12307.patch


On line 317, there is a php version check because of function stream_resolve_include_path. But it is available since 5.3.2, not since 5.3.0, so it fails on 5.3.0 and 5.3.1.


Posted by Martin Hujer (mhujer) on 2012-06-30T12:30:44.000+0000

Attaching patch

Posted by Sascha-Oliver Prolic (prolic) on 2012-06-30T14:25:47.000+0000

Zend Framework 2 requires PHP 5.3.3 or later

Posted by Martin Hujer (mhujer) on 2012-06-30T14:34:02.000+0000

Yeah, but not the ZF 1.12 where the new autoloaders were backported...

Posted by Rob Allen (rob) on 2012-06-30T19:28:10.000+0000

Resolved in svn r25006 and r25007.

Have you found an issue?

See the Overview section for more details.


© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.