Issues

ZF-12419: Fatal exceptions after 4 flawless years

Issue Type: 1.x to 2.x Integration Created: 2012-09-14T06:18:51.000+0000 Last Updated: 2012-11-16T16:55:48.000+0000 Status: Closed Fix version(s): Reporter: karen bridges (karenbridgeses) Assignee: Matthew Weier O'Phinney (matthew) Tags: - Zend_Controller

  • state:need-feedback

Related issues: Attachments:

Description

I have had Zend installed on my website for four years without incident. Two weeks ago it stopped working and my shopping cart doesn't complete orders. My webhost cannot help so I'm here looking for possible answers. In truth I don't know what version it is but maybe you'll know being that it was installed in 2008.

Originally the 'send order' button went to a blank page on Firefox and produced an Error 500 on IE. Subsequently I received this specific error:

[code]Fatal error: Uncaught exception 'Zend_Exception' with message 'File "Com.php" was loaded but class "Zend_Validate_Hostname_Com" was not found in the file' in /home/sites/topdogrecords.co.uk/public_html/shop/library/Zend/Loader.php:95 Stack trace: #0 /home/sites/topdogrecords.co.uk/public_html/shop/library/Zend/Validate/Hostname.php(331): Zend_Loader::loadClass('Zend_Validate_H...') #1 /home/sites/topdogrecords.co.uk/public_html/shop/library/Zend/Validate/EmailAddress.php(178): Zend_Validate_Hostname->isValid('gmail.com') #2 /home/sites/topdogrecords.co.uk/public_html/shop/library/Plugin/Zenamax.php(179): Zend_Validate_EmailAddress->isValid('soulgirl@gmail....') #3 /home/sites/topdogrecords.co.uk/public_html/shop/library/Plugin/Zenamax.php(157): Plugin_Zenamax->valInputFields('email', Array) #4 /home/sites/topdogrecords.co.uk/public_html/shop/application/controllers/CartController.php(97): Plugin_Zenamax->validateFields(Array, Array) #5 /home/sites/topdogrecords.co.uk/public_html/shop/library/Zend/Controller/Action.php(497 in /home/sites/topdogrecords.co.uk/public_html/shop/library/Zend/Loader.php on line 95[/code]

I have error logs if they'll help anyone. I'm not an expert and am just trying to get my website up and running again. Any help will be appreciated. My site is running PHP5.

Comments

Posted by Rob Allen (rob) on 2012-11-16T16:55:48.000+0000

Please ask support questions on the mailing lists (http://akrab.at/zfmailinglists) or on Stack Overflow.

Have you found an issue?

See the Overview section for more details.

Copyright

© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.

Contacts