ZF-12442: libxml_disable_entity_loader() call in ZF 1.12

Issue Type: Bug Created: 2012-10-15T13:23:16.000+0000 Last Updated: 2012-11-21T13:49:20.000+0000 Status: Resolved Fix version(s): - 1.12.1 (18/Dec/12)

Reporter: Karel Trcalek (kareltrcalek) Assignee: Rob Allen (rob) Tags: - Zend_Soap_Server

Related issues: Attachments:


Hi, I have updated from ZF 1.11 to ZF 1.12 and found that I can`t use my SOAP calls. In Zend/Soap/Server.php on line 732 is method libxml_disable_entity_loader() called, but this method is available from PHP >= 5.2.11. I am running on

<pre class="highlight">PHP 5.2.0-8+etch16 (cli)

and actually can not update until some issues are fixed or reimplemented. In install requirements instructions for ZF 1.12 you write that you need minimum PHP 5.2.4 or later (…) so that is also my fault we run on 5.2.0 but this method libxml_disable_entity_loader() is only available from PHP 5.2.11. (…) So do you think about providing some patch for this (that would be just awesome) or will you update the requirements install instructions for ZF 1.12 for this issue and change the minimal version from 5.2.4 as you write to 5.2.11?

<pre class="highlight">
Zend recommends the most current release of PHP for critical security and performance enhancements, and currently supports PHP 5.2.11 or later.

Thank you very much for your time&effort!


Posted by Rob Allen (rob) on 2012-11-20T20:17:28.000+0000

As this is the result of a security fix, we have updated the minimum version of PHp for ZF 1.12 to be 5.2.11

Posted by Karel Trcalek (kareltrcalek) on 2012-11-21T09:48:18.000+0000

Hi, thank you for new info. In ZF v. 1.12. documentation is still written PHP 5.2.4 Thanks for your time.

Posted by Rob Allen (rob) on 2012-11-21T10:08:31.000+0000


Where are you looking? The change so far has been made in the source code.

Posted by Karel Trcalek (kareltrcalek) on 2012-11-21T10:16:30.000+0000

Hi, here, to reference manual… Karel

Posted by Rob Allen (rob) on 2012-11-21T13:49:20.000+0000

Okay. That should automatically change when we release 1.12.1.

Have you found an issue?

See the Overview section for more details.


© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.