ZF-1830: No such file, Zend/Json/AllTests.php, in Zend/AllTests.php

Issue Type: Unit Tests: Problem Created: 2007-08-08T07:39:10.000+0000 Last Updated: 2008-03-21T16:25:35.000+0000 Status: Resolved Fix version(s): - 1.5.0 (17/Mar/08)

Reporter: Luke Crouch (lcrouch) Assignee: Bill Karwin (bkarwin) Tags: - Zend_Json

Related issues: - ZF-1840

Attachments: - ZF-1830.patch


zf/tests lcrouch$ phpunit AllTests.php

Warning: require_once(Zend/Json/AllTests.php): failed to open stream: No such file or directory in /Users/lcrouch/www/zf/tests/Zend/AllTests.php on line 74

Fatal error: require_once(): Failed opening required 'Zend/Json/AllTests.php' (include_path='/Users/lcrouch/www/zf/library:/Users/lcrouch/www/zf/tests:.:/Applications/xampp/xamppfiles/lib/php:/Applications/xampp/xamppfiles/lib/php/pear:/Users/lcrouch/www/zf/library:Users/lcrouch/www/zf/test') in /Users/lcrouch/www/zf/tests/Zend/AllTests.php on line 74


Posted by Luke Crouch (lcrouch) on 2007-08-08T07:42:34.000+0000

This patch changes the require from Zend/Json/AllTests.php to Zend/Json/JsonXMLTest.

It fixes the problem of not being able to run AllTests, but it might not be the best solution.

Posted by Luke Crouch (lcrouch) on 2007-08-08T13:30:23.000+0000

Here's the proposed code patch in a comment here for easy reading:

Index: tests/Zend/AllTests.php

--- tests/Zend/AllTests.php (revision 6038) +++ tests/Zend/AllTests.php (working copy) @@ -71,7 +71,7 @@ require_once 'Zend/VersionTest.php'; require_once 'Zend/ViewTest.php'; require_once 'Zend/XmlRpc/AllTests.php'; -require_once 'Zend/Json/AllTests.php'; +require_once 'Zend/Json/JsonXMLTest.php';

class Zend_AllTests

Posted by Darby Felton (darby) on 2007-08-09T09:59:19.000+0000

Assigning to [~matthew] to initiate issue review.

Posted by Bill Karwin (bkarwin) on 2007-09-11T17:54:19.000+0000

Resolved test configuration.

Have you found an issue?

See the Overview section for more details.


© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.