Issues

ZF-2125: Sqlite Cache Backend throws an Exception when the sqlite extension is not loaded

Issue Type: Improvement Created: 2007-10-31T10:36:36.000+0000 Last Updated: 2008-03-21T16:25:21.000+0000 Status: Resolved Fix version(s): - 1.5.0 (17/Mar/08)

Reporter: Deniz Adrian (deniz.adrian) Assignee: Fabien MARTY (fab) Tags: - Zend_Cache

Related issues: Attachments: - Sqlite.php.diff

Description

Sqlite Cache Backend throws an Exception when the sqlite extension is not loaded, which wasn't the case before.

Comments

Posted by Fabien MARTY (fab) on 2007-10-31T12:29:52.000+0000

I don't understand. In the last SVN revision (6679, 23/10/07) of the "Sqlite.php" file, there is :

<pre class="literal"> 
if (!extension_loaded('sqlite')) {
        Zend_Cache::throwException("Cannot use SQLite storage because the 'sqlite' extension is not loaded in the current PHP environment");
}

in the constructor.

so, it's ok, isn't it ?

Posted by Deniz Adrian (deniz.adrian) on 2007-10-31T13:18:08.000+0000

Oh sorry, it seems i wasn't working on the SVN head. Can be closed ;-)

Have you found an issue?

See the Overview section for more details.

Copyright

© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.

Contacts