ZF-2529: Make Zend_Db_Statement_Mysqli incorporate with PHP 5.3 and mysqlnd

Issue Type: Improvement Created: 2008-01-30T10:56:55.000+0000 Last Updated: 2012-03-14T00:53:20.000+0000 Status: Closed Fix version(s): - 1.9.0 (31/Jul/09)

Reporter: Lars Strojny (lars) Assignee: Ralph Schindler (ralph) Tags: - Zend_Db_Adapter_Mysqli

Related issues: - ZF-7081

Attachments: - zend_db_statement-mysqli.diff


mysqli_stmt_bind_param() expects bind parameters to be references, not values. The following patch ensures that references are given.


Posted by Lars Strojny (lars) on 2008-01-31T06:50:15.000+0000

See for details

Posted by Lars Strojny (lars) on 2008-01-31T06:53:59.000+0000

Updated the patch. The type definition should not be a reference.

Posted by Wil Sinclair (wil) on 2008-03-25T20:43:56.000+0000

Please categorize/fix as needed.

Posted by Olivier Doucet (ezameku) on 2008-08-21T10:12:10.000+0000


Any news about this patch ? I have to apply it to every release I get from ZF Website. It is a fix to a major bug I think.

Posted by Wil Sinclair (wil) on 2009-01-13T10:38:10.000+0000

Reassigning to Ralph to bring closure to this issue.

Posted by Chris Tankersley (dragonmantank) on 2009-05-24T09:46:39.000+0000

I applied the 1/31/08 patch against Zend Framework 1.8.1 and still get this issue with PHP 5.3 RC built on 5/21/09. Any news on this bug?

Posted by Constantine Karnacevych (digital) on 2009-05-25T17:05:54.000+0000

strange thing, i've applied this path and everything work well. perhaps you've either missed something or applied a path incorrectly. besides, this path would make sense after php 5.3 is released and it should be rearranged to gain back and forth compatibility

Posted by Olivier Doucet (ezameku) on 2009-05-27T06:51:22.000+0000

This patch still need to be applied on ZF 1.8.1 when used with PHP 5.3RC2.

Posted by Chris Tankersley (dragonmantank) on 2009-05-27T18:56:22.000+0000

Reapplied the patch and it worked this time, so I must have done something wrong the first time.

Any ideas when this will make it into trunk or is it just planned to be among the updates for Zend Framework to work with 5.3?

Posted by Edward Surov (zooh) on 2009-07-01T05:11:44.000+0000

I invented the same bicycle today when my site stopped working after upgrading to PHP 5.3.0 (released yesterday). I think it's time to fix the trunk already.

Posted by Ralph Schindler (ralph) on 2010-01-11T07:08:36.000+0000

Ill run the tests one more time and close, this was fixed in 1.9.0 release though.


Have you found an issue?

See the Overview section for more details.


© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.