ZF-2803: PHP 5.3 compatibility for Zend_Cache_Backend_File

Issue Type: Improvement Created: 2008-03-04T14:44:10.000+0000 Last Updated: 2009-07-21T02:54:10.000+0000 Status: Resolved Fix version(s): - 1.5.0 (17/Mar/08)

Reporter: Lars Strojny (lars) Assignee: Fabien MARTY (fab) Tags: - Zend_Cache

Related issues: Attachments: - 006-Zend_Cache-php53_deprecates_magic_quotes.diff


Zend_Cache_Backend_File checks for runtime magic quotes. The following patch a) checks whether the function is available (as the functions are removed in PHP 6) and b) suppresses the E_DEPRECATED warning.


Posted by Fabien MARTY (fab) on 2008-03-07T12:08:17.000+0000

fixed in SVN trunk (thanks)

Posted by Lars Strojny (lars) on 2008-03-07T16:20:25.000+0000

Sorry, but your fix is incomplete. PHP 5.3 introduces E_DEPRECATED. E_DEPRECATED is part of E_STRICT and when set/get_magic_quotes() is called, a deprecation warning is thrown. This means, you have to disable errors with @ in addition to checking whether the function is available as like I did it in my original patch.

Posted by Fabien MARTY (fab) on 2008-03-07T17:28:24.000+0000

(again) many thanks

Posted by Wil Sinclair (wil) on 2008-03-21T17:05:28.000+0000

This issue should have been fixed for the 1.5 release.

Posted by Wim Joris (oxidiser) on 2009-07-21T02:53:39.000+0000

Yes, error suppression is very nice in a production environment, but my development environment does not suppress errors/notices and this problem still persists.

Please fix this, it should not use a deprecated function.

Thank you for your work!

Have you found an issue?

See the Overview section for more details.


© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.