ZF-2831: Incorrect minimal required PHP version in README

Issue Type: Docs: Problem Created: 2008-03-07T16:19:08.000+0000 Last Updated: 2008-06-15T20:48:09.000+0000 Status: Resolved Fix version(s): - 1.5.0 (17/Mar/08)

Reporter: Wojciech Szela (wojciech.szela) Assignee: Thomas Weidner (thomas) Tags: Related issues: Attachments:


README.txt file states in system requirements "Zend Framework requires PHP 5.1.4 or later" but according to issue ZF-1828 minimal required version is 5.2.1.


Posted by Thomas Weidner (thomas) on 2008-03-08T08:13:51.000+0000

The minimum requirement for the complete framework is PHP 5.1.4

As behaviour in PHP itself is changed it can be that several special cases do not work or have to be reworked in a special PHP version. But this is always written in the manual.

So if there is a issue with a special PHP Version in a component of ZF it has to be documented, but this does not mean that the complete framework can only be used with this version.

Posted by Wil Sinclair (wil) on 2008-03-21T17:05:34.000+0000

This issue should have been fixed for the 1.5 release.

Posted by Wil Sinclair (wil) on 2008-06-15T20:48:09.000+0000

Changing to comply with new IT coventions for components.

Have you found an issue?

See the Overview section for more details.


© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.