Issues

ZF-2936: Fatal error: Class 'Zend_Loader_PluginLoader_Exception' not found in [...]Zend\Loader\PluginLoader.php on line 316

Issue Type: Bug Created: 2008-03-20T17:26:31.000+0000 Last Updated: 2008-03-31T16:07:18.000+0000 Status: Resolved Fix version(s): - 1.5.1 (25/Mar/08)

Reporter: EV (evalder) Assignee: Ralph Schindler (ralph) Tags: - Zend_Loader

Related issues: Attachments:

Description

Reproduce: index.php:

<pre class="highlight">
require_once 'Zend/Form.php';
$form = new Zend_Form(array(
    'elements' => array(
        'submit' => 'submit'
    )
));
$form->addElementPrefixPath('My_Decorator', './decorators/', 'decorator');
$form->submit->setDecorators(array('My'));

and create an empty file "./decorators/My.php".

This will trigger the error "Fatal error: Class 'Zend_Loader_PluginLoader_Exception' not found in [...]Zend\Loader\PluginLoader.php on line 316".

Suggested solution: Add the following line to Zend\Loader\PluginLoader.php at line 316.

<pre class="highlight">
                        Zend_Loader::loadClass('Zend_Loader_PluginLoader_Exception');

Comments

Posted by julien PAULI (doctorrock83) on 2008-03-21T03:39:56.000+0000

Fixed in trunk at r8949

Posted by Wil Sinclair (wil) on 2008-03-21T17:09:03.000+0000

I'm assuming this fix is merged to the 1.5 release branch for release with 1.5.1. Please update JIRA if this is not the case.

Posted by Wil Sinclair (wil) on 2008-03-31T16:07:17.000+0000

Please evaluate and assign as necessary.

Have you found an issue?

See the Overview section for more details.

Copyright

© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.

Contacts