ZF-3072: Support for DB2 on i5

Issue Type: Improvement Created: 2008-04-08T13:22:56.000+0000 Last Updated: 2012-10-30T05:05:34.000+0000 Status: Closed Fix version(s): - 1.8.0 (30/Apr/09)

Reporter: Wil Sinclair (wil) Assignee: Ralph Schindler (ralph) Tags: - Zend_Db_Adapter_Db2

Related issues: - ZF-905

Attachments: - As400.php


This is a general improvement for whatever changes are required for the DB2 adapter on i5. We will coordinate with our i5 team and Tripp Lite on a solution. We should be able to test in a i5 test environment devoted to framework.


Posted by old of Satoru Yoshida ( on 2008-09-01T21:37:54.000+0000

make link to ZF-3843

Posted by Piotr Kabacinski (kabot) on 2008-10-11T12:50:26.000+0000

As mentioned in [ZF-905] it looks like it's good attitude to create many subadapters for odbc. Becouse i need adapter for odbc/as400 for pdo i created class Zend_Db_Adapter_Pdo_Odbc_As400 - it strongly based on incubator version Zend_Db_Adapter_Db2 but it's simpler, just to fits my needs.

Db2 and db2/as400 have many differences so maybe it's reasonable to separate it into two classes?


Posted by Piotr Kabacinski (kabot) on 2008-10-11T12:52:20.000+0000


Posted by Ralph Schindler (ralph) on 2009-01-10T11:49:18.000+0000

Fixed in ZF 1.7.2

Have you found an issue?

See the Overview section for more details.


© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.