Issues

ZF-3697: Missing Zend_Feed_Rss lastBuildDate channel element

Issue Type: Bug Created: 2008-07-20T07:53:07.000+0000 Last Updated: 2012-03-21T11:02:32.000+0000 Status: Resolved Fix version(s): - 1.7.5 (16/Feb/09)

Reporter: John Reuning (jreuning) Assignee: Satoru Yoshida (satoruyoshida) Tags: - Zend_Feed

Related issues: Attachments:

Description

At least I assume this is a bug. Maybe there's something inherently bad about the lastBuildDate element? Here's a patch for Zend/Feed/Rss.php in version 1.5.2. This line is missing going back at least as far as version 1.0.3.

<pre class="highlight">
@@ -147,6 +147,7 @@
 
    if (isset($array->published)) {
        $lastBuildDate = $this->_element->createElement('lastBuildDate', gmdate('r', $array->published));
+       $channel->appendChild($lastBuildDate);
    }
 
    $editor = '';

Comments

Posted by Benjamin Eberlei (beberlei) on 2008-11-08T00:30:07.000+0000

Reevaluated to Major

Posted by old of Satoru Yoshida (yoshida@zend.co.jp) on 2009-01-31T04:09:53.000+0000

Solved in SVN r13892

Posted by Benjamin Eberlei (beberlei) on 2009-01-31T04:13:32.000+0000

You HAVE to attach Unittests to such bugfixes Yoshida. Have you run the testsuite to check that everything still works?

Posted by old of Satoru Yoshida (yoshida@zend.co.jp) on 2009-02-01T17:49:21.000+0000

Oh, Sorry for not attaching unittests. It causes BC?

Posted by old of Satoru Yoshida (yoshida@zend.co.jp) on 2009-02-02T17:52:18.000+0000

Sorry, not in 1.7.4. please wait.

Posted by old of Satoru Yoshida (yoshida@zend.co.jp) on 2009-02-16T20:04:45.000+0000

I ensure to be released in 1.7.5 .

Have you found an issue?

See the Overview section for more details.

Copyright

© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.

Contacts