ZF-3783: SubControllers in default module create invalid helper prefix

Issue Type: Bug Created: 2008-07-28T14:26:28.000+0000 Last Updated: 2008-09-02T10:39:25.000+0000 Status: Resolved Fix version(s): - 1.6.0 (02/Sep/08)

Reporter: Matthew Weier O'Phinney (matthew) Assignee: Matthew Weier O'Phinney (matthew) Tags: - Zend_Loader

Related issues: Attachments: -


Currently, when using sub controllers in the default module, a helper path based on the leading path segment is created, instead of using the default. For example:

<pre class="highlight">

application/views/helpers/SomeHelper.php would contain the class Zend_View_Helper_SomeHelper. If an action in Admin_FooController is invoked and the view calls the someHelper() helper, it will attempt to resolve it to Admin_View_Helper_SomeHelper and not find it.


Posted by Matthew Weier O'Phinney (matthew) on 2008-07-28T18:10:50.000+0000

Fixed in trunk and 1.6 release branch

Posted by michael depetrillo (klassicd) on 2008-07-29T00:42:19.000+0000

This is still broken. I just checked revision 10525.

Posted by Matthew Weier O'Phinney (matthew) on 2008-07-29T06:54:10.000+0000

If you feel it is still broken, then I need a reproduce case. This should include the minimal amount of application structure necessary to reproduce the issue. I will re-open the issue once you have posted a reproduce case.

Posted by Zoran Lazic (zoki) on 2008-07-30T04:16:14.000+0000

This is minimum setup for recreate of bug. Zip includes bootstrap and module Admin, View Helper and view scripts.

Posted by Matthew Weier O'Phinney (matthew) on 2008-08-07T07:01:08.000+0000

Unfortunately, you're using so many non-standard options, it's difficult to track down the issue.The combination of (a) not specifying a default module name (b) using non-standard paths in the ViewRenderer, and (c) not utilizing the error handler plugin is not helping unmask the problem. I'm attaching a tarball that does show the issue, however, using default settings for most cases.

Posted by Matthew Weier O'Phinney (matthew) on 2008-08-07T07:04:23.000+0000

Simplified example. Navigate to /admin/index/test to see the issue.

Posted by Matthew Weier O'Phinney (matthew) on 2008-08-07T07:28:57.000+0000

Re-marking as Zend_Loader issue. Fixed in trunk and 1.6 release branch.

Posted by Wil Sinclair (wil) on 2008-09-02T10:39:25.000+0000

Updating for the 1.6.0 release.

Have you found an issue?

See the Overview section for more details.


© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.