ZF-3978: Zend_Session_Namespace is PHP 5.3 incompatible

Issue Type: Bug Created: 2008-08-18T01:07:57.000+0000 Last Updated: 2008-09-02T10:39:28.000+0000 Status: Resolved Fix version(s): - 1.6.0 (02/Sep/08)

Reporter: Pawel Przeradowski (squeaky) Assignee: Matthew Weier O'Phinney (matthew) Tags: - Zend_Session

Related issues: Attachments:


PHP 5.3 will warn about __get magic call not being public.

Warning: The magic method __get() must have public visibility and can not be static in /home/squeaky/workspace/www/squeaky/lib/Zend/Session/Namespace.php on line 247


<pre class="highlight">
protected function & __get($name)


<pre class="highlight">
public function & __get($name)

resolves issue.


Posted by Olivier Doucet (ezameku) on 2008-08-22T11:25:05.000+0000

Bug confirmed with PHP 5.3.0alpha2-dev Snapshot used : 21 Aug 2008 20:04:06 -0400

Posted by Matthew Weier O'Phinney (matthew) on 2008-08-22T14:57:41.000+0000

Scheduling for RC3.

Posted by Matthew Weier O'Phinney (matthew) on 2008-08-24T07:44:18.000+0000

Fixed in trunk and 1.6 release branch

Posted by Wil Sinclair (wil) on 2008-09-02T10:39:28.000+0000

Updating for the 1.6.0 release.

Have you found an issue?

See the Overview section for more details.


© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.