Issues

ZF-4410: Apparent missing file: Zend/Validate/Hostname/Name.php

Issue Type: Bug Created: 2008-09-29T02:37:19.000+0000 Last Updated: 2011-08-20T14:52:51.000+0000 Status: Resolved Fix version(s): Reporter: SignpostMarv Martin (signpostmarv) Assignee: Satoru Yoshida (satoruyoshida) Tags: - Zend_Validate

Related issues: - ZF-2900

Attachments:

Description

exception 'uhu_error_exception' with message 'fopen(Zend/Validate/Hostname/Name.php): failed to open stream: No such file or directory' in S:\uhu private SVN\libs\Zend\Loader.php:160 Stack trace:

0 [internal function]: uhu_error_exception::error(2, 'fopen(Zend/Vali...', 'S:\uhu private ...', 160, Array)

1 S:\uhu private SVN\libs\Zend\Loader.php(160): fopen('Zend/Validate/H...', 'r', true)

2 S:\uhu private SVN\libs\Zend\Validate\Hostname.php(327): Zend_Loader::isReadable('Zend/Validate/H...')

3 S:\uhu private SVN\libs\Zend\Uri\Http.php(425): Zend_Validate_Hostname->isValid('blog.signpostma...')

4 S:\uhu private SVN\libs\Zend\Uri\Http.php(259): Zend_Uri_Http->validateHost()

5 S:\uhu private SVN\libs\Zend\Uri\Http.php(134): Zend_Uri_Http->valid()

6 S:\uhu private SVN\libs\Zend\Uri.php(123): Zend_Uri_Http->__construct('http', '//blog.signpost...')

7 S:\uhu private SVN\libs\Zend\Http\Client.php(251): Zend_Uri::factory('http://blog.sig...')

8 S:\uhu private SVN\libs\Zend\Http\Client.php(237): Zend_Http_Client->setUri('http://blog.sig...')

9 S:\uhu private SVN\libs\Zend\OpenId\Consumer.php(475): Zend_Http_Client->__construct('http://blog.sig...', Array)

10 S:\uhu private SVN\libs\Zend\OpenId\Consumer.php(704): Zend_OpenId_Consumer->_httpRequest('http://blog.sig...', 'GET', Array, NULL)

11 S:\uhu private SVN\libs\Zend\OpenId\Consumer.php(794): Zend_OpenId_Consumer->_discovery('http://blog.sig...', NULL, NULL)

12 S:\uhu private SVN\libs\Zend\OpenId\Consumer.php(145): Zend_OpenId_Consumer->_checkId(false, 'http://blog.sig...', NULL, NULL, NULL, NULL)

13 S:\localhost\OpenID\consumer.php(24): Zend_OpenId_Consumer->login('http://blog.sig...')

14 {main}

Comments

Posted by Wil Sinclair (wil) on 2008-10-10T01:28:39.000+0000

Can you please verify?

Posted by old of Satoru Yoshida (yoshida@zend.co.jp) on 2008-10-29T21:38:31.000+0000

I think there is problem in isValid($value) function in Zend/Validate/Hostname.php .

If you use a top level domain name that are not in /Zend/Validate/Hostname directory but exists in $_validTlds array , this problem will happen.

Have you found an issue?

See the Overview section for more details.

Copyright

© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.

Contacts