Issues

ZF-4471: testOptions(Zend_Translate_Adapter_ArrayTest) unit tests failure

Issue Type: Unit Tests: Problem Created: 2008-10-03T10:58:16.000+0000 Last Updated: 2008-11-13T14:09:57.000+0000 Status: Resolved Fix version(s): - 1.7.0 (17/Nov/08)

Reporter: Alexander Veremyev (alexander) Assignee: Thomas Weidner (thomas) Tags: - Zend_Translate

Related issues: Attachments:

Description

{panel} 9) testOptions(Zend_Translate_Adapter_ArrayTest) Failed asserting that two arrays are equal. --- Expected +++ Actual @@ -1,8 +1,8 @@ Array ( - [testoption] => testkey - [clear] => + [clear] => 1 [scan] => [locale] => en [ignore] => . + [testoption] => testkey ) {panel}

Comments

Posted by Thomas Weidner (thomas) on 2008-10-07T14:39:33.000+0000

Alex, I can't verify this and related. clear should always be false as it's not set on true or 1. Do you have the same issue also when testing this testbed alone ? Or only when doing a AllTests ?

I expect that the cache or registry is set but not by this testbed and used.

Posted by Alexander Veremyev (alexander) on 2008-10-08T05:34:45.000+0000

Yeah, all Zend_Translate tests pass correctly if they runs separately.

Posted by Thomas Weidner (thomas) on 2008-10-08T12:12:24.000+0000

Probably fixed with r11751

Posted by Alexander Veremyev (alexander) on 2008-10-09T01:30:56.000+0000

Yes, fixed.

Posted by Wil Sinclair (wil) on 2008-11-13T14:09:57.000+0000

Changing issues in preparation for the 1.7.0 release.

Have you found an issue?

See the Overview section for more details.

Copyright

© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.

Contacts