ZF-4478: testUseManualFormat(Zend_Validate_DateTest)

Issue Type: Unit Tests: Problem Created: 2008-10-03T11:21:24.000+0000 Last Updated: 2008-11-13T14:10:03.000+0000 Status: Resolved Fix version(s): - 1.7.0 (17/Nov/08)

Reporter: Alexander Veremyev (alexander) Assignee: Thomas Weidner (thomas) Tags: - Zend_Validate

Related issues: Attachments:


{panel} 30) testUseManualFormat(Zend_Validate_DateTest) Failed asserting that is true. {panel}


Posted by Thomas Weidner (thomas) on 2008-10-04T02:30:51.000+0000

I can not verify this one... seems to brake on line 139 or 140:

<pre class="highlight">
        $this->assertTrue($this->_validator->setFormat('MMM yyyy')->isValid('Jan 2010'));

but works by me on 2 environments.

Can you please verify at which line the test brakes ? Thanks Alex

Posted by Alexander Veremyev (alexander) on 2008-10-08T05:00:34.000+0000

The problem is on line 140

It occures if whole tests suite runs and doesn't appear if only Zend_Validate tests are passed. So it may be side effect of some other tests.

Posted by Alexander Veremyev (alexander) on 2008-10-08T05:25:03.000+0000

Problem doesn't occure if Zend_Translate tests are turned off (as well as for [ZF-4476], [ZF-4477], [ZF-4479], [ZF-4481])

Posted by Thomas Weidner (thomas) on 2008-10-08T12:12:11.000+0000

Probably fixed with r11751

Posted by Alexander Veremyev (alexander) on 2008-10-09T01:30:37.000+0000

Yes, fixed.

Posted by Wil Sinclair (wil) on 2008-11-13T14:10:03.000+0000

Changing issues in preparation for the 1.7.0 release.

Have you found an issue?

See the Overview section for more details.


© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.