Issues

ZF-4530: testSetHttpClient(Zend_Auth_Adapter_OpenIdTest) unit tests failure

Issue Type: Unit Tests: Problem Created: 2008-10-09T01:36:27.000+0000 Last Updated: 2008-11-13T14:10:16.000+0000 Status: Resolved Fix version(s): - 1.7.0 (17/Nov/08)

Reporter: Alexander Veremyev (alexander) Assignee: Alexander Veremyev (alexander) Tags: - Zend_Http_Client

Related issues: Attachments:

Description

{panel} 1) testSetHttpClient(Zend_Auth_Adapter_OpenIdTest) --- Expected +++ Actual @@ -2,5 +2,5 @@ Host: id.myopenid.com Connection: close Accept-encoding: gzip, deflate -User-agent: Zend_OpenId +User-Agent: Zend_OpenId {panel}

Comments

Posted by Alexander Veremyev (alexander) on 2008-10-09T01:38:04.000+0000

Additional failure probably related to this one:

{panel} 3) testHttpRequest(Zend_OpenId_ConsumerTest) --- Expected +++ Actual @@ -2,5 +2,5 @@ Host: <www.myopenid.com> Connection: close Accept-encoding: gzip, deflate -User-agent: Zend_OpenId +User-Agent: Zend_OpenId {panel}

Posted by Alexander Veremyev (alexander) on 2008-10-09T11:03:28.000+0000

Only one failure is produced now and it's actually Zend_Http_Response related:

{panel} 2) testHttpRequest(Zend_OpenId_ConsumerTest) --- Expected +++ Actual @@ -3,4 +3,5 @@ Connection: close Accept-encoding: gzip, deflate User-Agent: Zend_OpenId +Content-Length: 0 {panel}

Posted by Jonathan Deutekom (deutekom) on 2008-10-10T05:50:50.000+0000

In my projects:

  • XML-RPC Request failure.
  • Login via VeriSign OpenId-Provider (pip.verisignlabs.com) with Zend_Auth_Adapter_OpenId und Simple Registration failure.

since 2008-10-07

Posted by Alexander Veremyev (alexander) on 2008-10-11T13:29:04.000+0000

Fixed with performed tests update and some Zend_Http_Client fixes.

Posted by Wil Sinclair (wil) on 2008-11-13T14:10:16.000+0000

Changing issues in preparation for the 1.7.0 release.

Have you found an issue?

See the Overview section for more details.

Copyright

© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.

Contacts