Issues

ZF-4621: Zend_Form_File does not work

Issue Type: Bug Created: 2008-10-16T23:48:28.000+0000 Last Updated: 2008-11-13T14:10:25.000+0000 Status: Resolved Fix version(s): - 1.7.0 (17/Nov/08)

Reporter: rollenc Luo (rollenc) Assignee: Thomas Weidner (thomas) Tags: - Zend_Form

Related issues: Attachments:

Description

I create a form with a ini config. But after upgrade ZF from 1.6.1, The file input does not work well. It show: Warning: Unknown file in D:\WorkProgram\php5\PEAR\Zend\Form\Element.php on line 1923

I got the trace as follow:

Zend_File_Transfer_Adapter_Abstract->getFilters('Avatar')

1 D:\WorkProgram\php5\PEAR\Zend\Form\Element.php(524): Zend_Form_Element_File->getFilters()

2 D:\WorkProgram\php5\PEAR\Zend\Form\Element.php(541): Zend_Form_Element->_filterValue(NULL, NULL)

3 D:\WorkProgram\php5\PEAR\Zend\Form\Decorator\ViewHelper.php(201): Zend_Form_Element->getValue()

4 D:\WorkProgram\php5\PEAR\Zend\Form\Decorator\ViewHelper.php(231): Zend_Form_Decorator_ViewHelper->getValue(Object(Zend_Form_Element_File))

5 D:\WorkProgram\php5\PEAR\Zend\Form\Element.php(1905): Zend_Form_Decorator_ViewHelper->render('')

6 D:\WorkProgram\php5\PEAR\Zend\Form\Element.php(1920): Zend_Form_Element->render()

7 D:\DevRep\SmarterV2CN\Source_Code\smarter_space\web\files\templates_c\%%9B^9B5^9B538F2C%%editprofile.tpl.php(112): Zend_Form_Element->__toString()

8 D:\WorkProgram\php5\Smarty-2.6.11\libs\Smarty.class.php(1265): include('D:\DevRep\Smart...')

9 D:\WorkProgram\php5\Smarty-2.6.11\libs\Smarty.class.php(1108): Smarty->fetch('User/editprofil...', NULL, NULL, true)

10 D:\DevRep\SmarterV2CN\Source_Code\smarter_space\web\lib\classes\action\class.BaseAction.php(572): Smarty->display('User/editprofil...')

11 D:\DevRep\SmarterV2CN\Source_Code\smarter_space\web\lib\classes\action\class.BaseAction.php(458): BaseAction->display(Object(HttpRequest), Object(HttpResponse))

12 D:\DevRep\SmarterV2CN\Source_Code\smarter_space\web\scripts\user.php(26): BaseAction->execute()

13 {main}"

Comments

Posted by Thomas Weidner (thomas) on 2008-10-17T09:32:46.000+0000

Seems that you are calling getValues() somewhere.

This issue has already been solved several days ago.

Posted by Wil Sinclair (wil) on 2008-11-13T14:10:25.000+0000

Changing issues in preparation for the 1.7.0 release.

Have you found an issue?

See the Overview section for more details.

Copyright

© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.

Contacts