ZF-4851: Problem with getFileInfo() in Zend_File_Transfer_Adapter_Abstract

Issue Type: Bug Created: 2008-11-07T05:32:05.000+0000 Last Updated: 2008-11-13T14:10:29.000+0000 Status: Resolved Fix version(s): - 1.7.0 (17/Nov/08)

Reporter: kasugai (kasugai) Assignee: Thomas Weidner (thomas) Tags: - Zend_File_Transfer

Related issues: Attachments:


I'm use… revision:12282

This code is Error.

$form->addElement('file', 'logo', array(
                    'required' => true,
                    'validators' => array(
                              array('Count', true, 2),
                              array('Size', true, "100KB"),
                              array('Extension', true, 'jpg'),
                    'multiFile' => 1,

Render page. Error occured....

Error is [ Warning: "logo" not found by file transfer adapter in... ].

Why error occured?

So i edited Zend/File/Transfer/Adapter/Abstract.php :: getFileInfo()

public function getFileInfo($file = null) { return $this->_getFiles($file); }

↓ It changed.

public function getFileInfo($file = null) { return $this->_getFiles($file, false, true); }

The error did not happen.

please fix this problem.


Posted by Thomas Weidner (thomas) on 2008-11-07T06:24:59.000+0000

There was an error in multifile which has been solved one or two days after the release has been fixed.

It is solved in 1.7.

Posted by Wil Sinclair (wil) on 2008-11-13T14:10:29.000+0000

Changing issues in preparation for the 1.7.0 release.

Have you found an issue?

See the Overview section for more details.


© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.