Issues

ZF-4988: Unable to use (former) Zend Tool in incubator with environment PATHs

Issue Type: Bug Created: 2008-11-19T03:03:26.000+0000 Last Updated: 2009-04-24T11:04:30.000+0000 Status: Resolved Fix version(s): - 1.8.0 (30/Apr/09)

Reporter: Sylvain ADAM (scorpe51) Assignee: Ralph Schindler (ralph) Tags: - Zend_Tool

Related issues: Attachments:

Description

Hi,

I tested Zend Tool with the brand new 1.7.0 version, and, the thing is that, it seems to me that there's an error in some tests for the file /incubator/bin/zf.php

From line 9: if ($zendFrameworkPathOverride = getenv('ZF_PATH') != '') { $zendFrameworkPath = $zendFrameworkPathOverride; }

$zendFrameworkPathOverride is always set as 1 if you got something in your ZF_PATH.

If you write the test on that way, this seems to work: if ('' != $zendFrameworkPathOverride = getenv('ZF_PATH'))

This really is a small thing, and it might be already fixed, or it's just bugging on my config, don't know.

Config: Windows XP SP3 PHP 5.2.6

Thank you.

Scorpe51

Comments

Posted by old of Satoru Yoshida (yoshida@zend.co.jp) on 2009-02-16T22:19:44.000+0000

Set component

Posted by Ralph Schindler (ralph) on 2009-04-24T11:04:29.000+0000

This has been resolved by the fix in ZF-6413. There is an error screen inside zf.php as well as forthcoming documentation on this issue.

Have you found an issue?

See the Overview section for more details.

Copyright

© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.

Contacts