ZF-5176: multiple calls with the same Zend_Rest_Client instance not working

Issue Type: Bug Created: 2008-12-06T22:20:01.000+0000 Last Updated: 2012-03-14T05:54:20.000+0000 Status: Resolved Fix version(s): - 1.7.2 (23/Dec/08)

Reporter: Onno Schmidt (fino69) Assignee: Satoru Yoshida (satoruyoshida) Tags: - Zend_Rest_Client

Related issues: Attachments:


I found a problem using 1 instance of Zend_Rest_Client and doing multiple calls with parameters to the same server. The problem is that the method is never being set in the data array with the second call.

This worked fine with version 1.6.2, so it looks like the last changes in the __call() method in Zend_Rest_Client broke the external interface.

I suggest to reset the data array after the call to the webservice is being made in the __call method. Or to create a reset() method for resetting the data array.

$client = new Zend_Rest_Client("http://localhost/service.php");


returns: Zend_Rest_Client Object ( [_data:protected] => Array ( [method] => getMoo [arg1] => 44 [getMoo] => 44 [rest] => 1 )


returns: Zend_Rest_Client Object ( [_data:protected] => Array ( [method] => getMoo [arg1] => 44 [getMoo] => 44 [rest] => 1 [getBlah] => 77 )



Posted by old of Satoru Yoshida ( on 2008-12-11T02:31:33.000+0000

Solved in SVN r13151

Have you found an issue?

See the Overview section for more details.


© 2006-2018 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.