Issues

ZF-6440: A set of "Zend_Loader::Zend_Loader::autoload is deprecated ..." and "Zend_Loader::Zend_Loader::registerAutoload is deprecated ..." errors

Issue Type: Unit Tests: Problem Created: 2009-04-27T06:49:08.000+0000 Last Updated: 2009-04-27T07:41:22.000+0000 Status: Resolved Fix version(s): - 1.8.0 (30/Apr/09)

Reporter: Alexander Veremyev (alexander) Assignee: Matthew Weier O'Phinney (matthew) Tags: - Zend_Loader

Related issues: Attachments:

Description

{panel} 1) testLoaderAutoloadLoadsValidClasses(Zend_LoaderTest) Zend_Loader::Zend_Loader::autoload is deprecated as of 1.8.0 and will be removed with 2.0.0; use Zend_Loader_Autoloader instead /home/cawa/ZendFramework/svn/framework/branches/release-1.8/library/Zend/Loader.php:186 /home/cawa/ZendFramework/svn/framework/branches/release-1.8/library/Zend/Loader.php:186

  1. testLoaderAutoloadFailsOnInvalidClasses(Zend_LoaderTest) Zend_Loader::Zend_Loader::autoload is deprecated as of 1.8.0 and will be removed with 2.0.0; use Zend_Loader_Autoloader instead /home/cawa/ZendFramework/svn/framework/branches/release-1.8/library/Zend/Loader.php:186 /home/cawa/ZendFramework/svn/framework/branches/release-1.8/library/Zend/Loader.php:186

  2. testLoaderRegisterAutoloadRegisters(Zend_LoaderTest) Zend_Loader::Zend_Loader::registerAutoload is deprecated as of 1.8.0 and will be removed with 2.0.0; use Zend_Loader_Autoloader instead /home/cawa/ZendFramework/svn/framework/branches/release-1.8/library/Zend/Loader.php:207 /home/cawa/ZendFramework/svn/framework/branches/release-1.8/library/Zend/Loader.php:207

  3. testLoaderRegisterAutoloadExtendedClassNeedsAutoloadMethod(Zend_LoaderTest) Zend_Loader::Zend_Loader::registerAutoload is deprecated as of 1.8.0 and will be removed with 2.0.0; use Zend_Loader_Autoloader instead /home/cawa/ZendFramework/svn/framework/branches/release-1.8/library/Zend/Loader.php:207 /home/cawa/ZendFramework/svn/framework/branches/release-1.8/library/Zend/Loader.php:207

  4. testLoaderRegisterAutoloadExtendedClassWithAutoloadMethod(Zend_LoaderTest) Zend_Loader::Zend_Loader::registerAutoload is deprecated as of 1.8.0 and will be removed with 2.0.0; use Zend_Loader_Autoloader instead /home/cawa/ZendFramework/svn/framework/branches/release-1.8/library/Zend/Loader.php:207 /home/cawa/ZendFramework/svn/framework/branches/release-1.8/library/Zend/Loader.php:207

  5. testLoaderRegisterAutoloadInvalidClass(Zend_LoaderTest) Zend_Loader::Zend_Loader::registerAutoload is deprecated as of 1.8.0 and will be removed with 2.0.0; use Zend_Loader_Autoloader instead /home/cawa/ZendFramework/svn/framework/branches/release-1.8/library/Zend/Loader.php:207 /home/cawa/ZendFramework/svn/framework/branches/release-1.8/library/Zend/Loader.php:207

  6. testLoaderUnregisterAutoload(Zend_LoaderTest) Zend_Loader::Zend_Loader::registerAutoload is deprecated as of 1.8.0 and will be removed with 2.0.0; use Zend_Loader_Autoloader instead /home/cawa/ZendFramework/svn/framework/branches/release-1.8/library/Zend/Loader.php:207 /home/cawa/ZendFramework/svn/framework/branches/release-1.8/library/Zend/Loader.php:207 {panel}

Comments

Posted by Matthew Weier O'Phinney (matthew) on 2009-04-27T07:41:19.000+0000

These were due to marking autoload() and registerAutoload() as deprecated. I've added error handling and assertions now that correct the problem.

Have you found an issue?

See the Overview section for more details.

Copyright

© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.

Contacts