Issues

ZF-6460: Stripping all require_once calls makes Zend_Loader_Autoloader unable to work

Issue Type: Docs: Problem Created: 2009-04-28T23:57:15.000+0000 Last Updated: 2009-04-29T08:33:48.000+0000 Status: Resolved Fix version(s): - 1.9.0 (31/Jul/09)

Reporter: Michael Contento (kaffeefleck) Assignee: Matthew Weier O'Phinney (matthew) Tags: - Zend_Loader

Related issues: Attachments:

Description

h4. What?

if you follow this step of the documentation: Classloading performance. Zend_Loader_Autoloader does not longer work!

h4. Why? Because Zend_Loader_Autoloader requires Zend_Loader - but we strip out the required "require 'Zend/Loader.php';".

h4. Solution? Change the documentation to something like this:

<pre class="literal"> 
% cd path/to/ZendFramework/library
% find . -name '*.php' -not -wholename '*/Loader/Autoloader.php' -print0 | xargs -0 \
  sed --regexp-extended --in-place 's/(require_once)/\/\/ \1/g'

Comments

Posted by Matthew Weier O'Phinney (matthew) on 2009-04-29T08:33:45.000+0000

Fixed in trunk and 1.8 release branch; will update on site with 1.8 release.

Have you found an issue?

See the Overview section for more details.

Copyright

© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.

Contacts