Issues

ZF-6672: autoloading issue in Zend_Application_Bootstrap_BootstrapAbstract::getPluginResource

Issue Type: Bug Created: 2009-05-15T04:32:57.000+0000 Last Updated: 2009-08-10T07:37:19.000+0000 Status: Resolved Fix version(s): - 1.9.1 (11/Aug/09)

Reporter: Martin Adler (madler) Assignee: Matthew Weier O'Phinney (matthew) Tags: - Zend_Application

Related issues: - ZF-6658

Attachments:

Description

There is an autoloading issue that only occurs when a module bootstrap is loaded. In my case this leads to the following warnings

Warning: include(FrontController.php) [function.include]: failed to open stream: No such file or directory in /path/to/library/Zend/Loader.php on line 83

Warning: include() [function.include]: Failed opening 'FrontController.php' for inclusion (include_path='/path/to/library:.:/usr/local/lib/php') in /path/to/library/Zend/Loader.php on line 83

I could work around this issue, when I set the second parameter of class_exists to false at Zend_Application_Bootstrap_BootstrapAbstract::getPluginResource() on line 352.

Comments

Posted by Dolf Schimmel (Freeaqingme) (freak) on 2009-05-29T10:09:31.000+0000

Did you test this against 1.8.2? I think it was resolved already (not sure though).

Posted by Martin Adler (madler) on 2009-05-29T11:05:25.000+0000

I have tested this also against 1.8.2 Release (r15776) that I've downloaded today. This only occurs when the fallback autoloader is enabled.

Posted by Jurrien Stutterheim (norm2782) on 2009-06-24T21:29:49.000+0000

Could you try and reproduce this issue with 1.8.4? The solution to ZF-7002 might have fixed this.

Posted by Marian Meres (marian.meres) on 2009-06-25T00:42:25.000+0000

I confirm that the issue is still there in 1.8.4. More here: http://www.nabble.com/setFallbackAutoloader(true)-causing-module-boostraps-not-load-td24113679.html#a24113679

Posted by Matthew Weier O'Phinney (matthew) on 2009-06-25T04:01:51.000+0000

Can you confirm against current trunk? I suspect that the fix in ZF-7002 did not make it into 1.8.4 as I don't see that the fix was merged to the 1.8 release branch.

Posted by Marian Meres (marian.meres) on 2009-06-26T07:33:00.000+0000

Confirm still an issue under current r16310. ZF-6658 seem to be reporting the same...

Posted by Jurrien Stutterheim (norm2782) on 2009-06-27T15:47:32.000+0000

Matthew: the merge to release-1.8 is nowhere to be seen in FishEye, but I can see it in the release-1.8 code.

Posted by Matthew Weier O'Phinney (matthew) on 2009-08-06T10:40:05.000+0000

Patch in ZF-7224 applied to trunk and 1.9 release branch.

Have you found an issue?

See the Overview section for more details.

Copyright

© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.

Contacts