ZF-6827: Fatal error: Call to a member function setFetchMode() on a non-object in /var/www/html/library/Zend/Db/Statement/Pdo.php on line 426

Issue Type: Bug Created: 2009-05-27T16:54:10.000+0000 Last Updated: 2009-05-27T18:09:37.000+0000 Status: Resolved Fix version(s): Reporter: Jonathan Block (block.jon) Assignee: Dolf Schimmel (Freeaqingme) (freak) Tags: - Zend_Db

Related issues: Attachments:


I get the "Call to a member function setFetchMode() on a non-object" with a segmentation fault when i run this code:

    $locationTable = new DatabaseTable_Location();
    $locationRow = $locationTable->fetchRow('id = ' . $locationid);

and when $locationid is null.

please advise. How do I find the version of zend framework? I downloaded it a couple of months ago...



Posted by Dolf Schimmel (Freeaqingme) (freak) on 2009-05-27T16:59:29.000+0000

Do you get an exception, or a segfault?

You can find the version of ZF by looking in /library/Zend/Version.php . If you could test this against 1.8.2 or trunk it would be highly appreciated.

Posted by Jonathan Block (block.jon) on 2009-05-27T17:49:04.000+0000

I was using 1.7.2!! Wow that's old.

I upgraded to 1.8.2. This issue seems to be resolved in 1.8.2 because I see a meaningful SQL error.

Thank you!!

Also, I tried to get the source from the svn trunk. Your "Readme.txt" indicates:

"The URL for the trunk of the Zend Framework SVN repository is:"

I therefore tried to "svn ls" but i get:

my-macbook-pro:library jon$ svn ls svn: URL '' non-existent in that revision

So, that's a different problem I suppose.

Posted by Dolf Schimmel (Freeaqingme) (freak) on 2009-05-27T18:09:37.000+0000

I'm closing this issue because it apparently was solved already.

What the URL is concerned, I opened up a new issue for that: ZF-6829

Have you found an issue?

See the Overview section for more details.


© 2006-2018 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.