ZF-6861: Stripping all require_once calls makes Zend_Application unable to work

Issue Type: Docs: Problem Created: 2009-05-29T12:22:26.000+0000 Last Updated: 2009-08-21T13:07:58.000+0000 Status: Resolved Fix version(s): - 1.9.2 (25/Aug/09)

Reporter: Michael Contento (kaffeefleck) Assignee: Matthew Weier O'Phinney (matthew) Tags: - Zend_Application

  • Zend_Loader

Related issues: Attachments:


h4. What?

If you follow this step of the documentation: Classloading performance. You have a problems with Zend_Application!

h4. Why? Because on line 74 and 290 Zend_Application use require_once - and thats what we are stripping out.

h4. Solution? Change the documentation to something like this (untested - but should work):

<pre class="literal"> 
% cd path/to/ZendFramework/library
% find . -name '*.php' -not -wholename '*/Loader/Autoloader.php' \
  -not -wholename '*/Application.php' -print0 | \
  xargs -0 sed --regexp-extended --in-place 's/(require_once)/\/\/ \1/g'


Posted by Mark Maynereid (mim) on 2009-07-23T08:20:48.000+0000

Seemed to fix the problem when I tried it. Thanks.

Posted by Matthew Weier O'Phinney (matthew) on 2009-08-21T13:07:58.000+0000

Tested and works perfectly. I've updated the manual page in trunk and the 1.9 release branch, and it will publish with 1.9.2.

Have you found an issue?

See the Overview section for more details.


© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.