ZF-6872: Reply-To support (encoding)

Issue Type: Bug Created: 2009-06-01T03:45:08.000+0000 Last Updated: 2009-06-25T18:40:42.000+0000 Status: Resolved Fix version(s): - 1.9.0 (31/Jul/09)

Reporter: J?nis (janis) Assignee: Benjamin Eberlei (beberlei) Tags: - Zend_Mail

Related issues: - ZF-7126



Reply-To field, when added with addHeader, is not encoded correctly if it contains non-Latin characters (I'm using UTF-8 charset).

There is no special function to add Reply-To field, so it's impossible to set the personal name and the address separately. But if they are set together and encoded together - I don't know if that complies with the standards, but at least MS Outlook doesn't understand the value correctly.


Posted by old of Satoru Yoshida ( on 2009-06-06T04:27:01.000+0000

Hi, I hope you would use setHeaderEncoding(Zend_Mime::ENCODING_BASE64) before addHeader.

Probably, encoding problem could be solved.

Posted by Benjamin Eberlei (beberlei) on 2009-06-12T14:18:35.000+0000

Can you explain exactly what you are calling? Although i understand the problem, i'd like to see some sample snippet to verify that i understand the behaviour correctly.

Posted by J?nis (janis) on 2009-06-13T05:46:26.000+0000


I tried to set Reply-To field to this:


In Outlook the header looks like this:

Reply-To: =?UTF-8?Q?"J=C4=81nis"=20<mail-91-129-d61e832y789uc2fd6c@mailgate.?= =?UTF-8?Q?>?=

And when I click on "Reply", the receivers address is filled with this:

Jānis <=?UTF-8?Q? J=C4=81nis =20<mail-91-129-d61e832y789uc2fd6c@mailgate.?= =?UTF-8?Q?>?=>

I'm not sure, maybe it would even work, but at least it looks ugly and wrong. :)

Posted by Benjamin Eberlei (beberlei) on 2009-06-13T07:44:45.000+0000

Added new function setReplyTo(). It correctly encodes the Reply-To header with name.

Will be included in next minor release.

Have you found an issue?

See the Overview section for more details.


© 2006-2018 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.