ZF-6988: error.phtml produced with invalid doctype

Issue Type: Bug Created: 2009-06-11T14:08:17.000+0000 Last Updated: 2011-08-03T15:33:00.000+0000 Status: Resolved Fix version(s): - 1.8.4 (23/Jun/09)

Reporter: Sander Bol (tubularbell) Assignee: Satoru Yoshida (satoruyoshida) Tags: - Zend_Tool

Related issues: Attachments:


The error.phtml generated by Zend_Tool, unlike the other view scripts, tries to pass itself off as being XHTML 1.0 Strict - however brave an attempt, the doctype that is produced is invalid. There are two issues with it:

  1. There should not be a ; between the two parts.
  2. The final double-quote is missing.

To fix this, change the doctype in error.phtml from: "http://<>> Into: ofollow" href="">">

Validator error for the semicolon: character ";" invalid: only delimiter ">", delimiter "[", system identifier, "CDATA", "NDATA", "SDATA" and parameter separators allowed


Posted by old of Satoru Yoshida ( on 2009-06-11T16:08:14.000+0000

Solved in SVN r16012

Have you found an issue?

See the Overview section for more details.


© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.