ZF-7002: Zend_Application_Resource_Modules class_exists shouldn't try to load bootstrap class

Issue Type: Bug Created: 2009-06-12T19:28:12.000+0000 Last Updated: 2009-06-24T20:48:53.000+0000 Status: Resolved Fix version(s): - 1.8.4 (23/Jun/09)

Reporter: Jurrien Stutterheim (norm2782) Assignee: Jurrien Stutterheim (norm2782) Tags: - Zend_Application

Related issues: Attachments:


On line 71, Zend_Application_Resource_Modules checks if the bootstrap class for a specific module is loaded using class_exists. However, the second argument for class_exists isn't set to false. The result is that the autoloader will try to load the bootstrap class automatically. This is not desirable if you don't want to create a bootstrap class for your modules. Also, the resource seems to already be setup to try and load the class if it's not loaded already. Suggested fix:


<pre class="highlight">


Posted by Jurrien Stutterheim (norm2782) on 2009-06-18T21:09:52.000+0000

Resolved in r16155 and merged to release-1.8 in r16156

Posted by Miroslav Kubelik (koubel) on 2009-06-20T08:26:08.000+0000

I think this partially solves ZF-6658.

Maybe same problem with class_exists is in ZF-6672, can you please reassign and fix ZF-6672 also?

Posted by Chris Jones (leeked) on 2009-06-24T20:48:34.000+0000

This fixes ZF-6707 also.

Have you found an issue?

See the Overview section for more details.


© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.